Call traffic / Puheluliikenne
Incident Report for Benemen Oy
Resolved
This incident has been resolved.
Posted Apr 29, 2021 - 16:50 EEST
Update
We are continuing to monitor for any further issues.
Posted Apr 29, 2021 - 15:59 EEST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Apr 29, 2021 - 15:59 EEST
Investigating
Dear Customer,
Benemen is investigating possible problem in part of telephony call traffic.

Hyvä asiakkaamme,
Benemen tutkii mahdollista ongelmaa osassa puheluliikennettä.
Posted Apr 29, 2021 - 15:27 EEST
This incident affected: BeneCloud (BeneCore).