BeneVoice for Salesforce
Incident Report for Enreach
Resolved
It appeared that the problem was not global, but concerned specific customer.
Posted Dec 05, 2021 - 09:56 EET
Investigating
We are currently investigating this issue.
Posted Dec 05, 2021 - 09:21 EET
This incident affected: Clients (Voice for Salesforce).